The free downloadable Let’s Explore app required to use your VR/AR Goggles and Holographic Explorer Cube is compatible with nearly all new and most relatively-new Apple (iOS) and Android smartphones. 


Please go to https://www.letsexplore.com/pages/supported-devices to check our compatibility list.